Gwiazdka nieaktywnaGwiazdka nieaktywnaGwiazdka nieaktywnaGwiazdka nieaktywnaGwiazdka nieaktywna
 

Za pomocą funkcji logicznej JEŻELI jesteśmy w stanie sprawdzić interesującą nas wartość. Jest jedną z najbardziej popularnych funkcji programu LibreOffice Calc. Funkcja zwraca dowolną wartość lub wyrażenie, które mogą przyjmować wartość prawda lub fałsz.

 

Funkcja JEŻELI LibreOffice Calc zawiera trzy argumenty:

  1. Test logiczny
  2. Wartość jeżeli prawda
  3. Wartość jeżeli fałsz

 

Składnia funkcji JEŻELI:

JEŻELI(Test logiczny; Wartość jeżeli prawda; Wartość jeżeli fałsz)

 

Funkcja JEŻELI przykłady

 

Przykład 1. Podstawowe zastosowanie, funkcja JEŻELI Calc

Sprawdzamy, czy podana wartość w komórce A1 jest większa od liczby 5 (rys. 1.):

=JEŻELI(A1>5;A1;"Wartość jest mniejsza od liczby 6")

 

Rys. 1.  Funkcja JEŻELI LibreOffice Calc

Rys. 1.  Funkcja JEŻELI LibreOffice Calc

 

Przykład 2. Rozbudowana funkcja JEŻELI Calc

Sprawdzamy, czy podana liczba w komórce A1 jest większa od 5 i mniejsza od 10 (rys. 2.):

=JEŻELI(A1>5;JEŻELI(A1<10;"Wartość jest większa od liczby 5 i mniejsza od liczby 10";"Wartość jest większa od liczby 9");"Wartość jest mniejsza od liczby 6")

 

Rys. 2. Rozbudowana funkcja JEŻELI Calc

Rys. 2. Rozbudowana funkcja JEŻELI Calc

 

Przykład 3. Łączenie warunków, funkcja I (Identyczne działanie jak funkcja ORAZ w programie Excel)

Sprawdzamy, czy spełnione są dwa warunki, wartość jest większa od 5 i mniejsza od 10 (rys. 3.):

=JEŻELI(I(A1>5;A1<10);"Wartość jest większa od liczby 5 i mniejsza od liczby 10";"Wartość jest mniejsza od liczby 6 lub większa od liczby 9") 

 

 Rys. 3. Rozbudowana funkcja JEŻELI Calc (Łączenie warunków, funkcja I)

Rys. 3. Rozbudowana funkcja JEŻELI Calc (Łączenie warunków, funkcja I)

 

Przykład 4. Łączenie warunków, funkcja LUB

Sprawdzamy, czy spełniony jest jeden z dwóch warunków. Wartość jest większa od 5 lub mniejsza od 1 (rys. 4.):

=JEŻELI(LUB(A1>5;A1<1);A1;"Wartość jest spoza zakresu")

 

Rys. 4.  Rozbudowana funkcja JEŻELI Calc (Łączenie warunków, funkcja LUB)

Rys. 4.  Rozbudowana funkcja JEŻELI Calc (Łączenie warunków, funkcja LUB)

 

Przykłady zostały zrealizowane na wersji LibreOffice 7.0.4.2.

 

Książki Helion