Gwiazdka nieaktywnaGwiazdka nieaktywnaGwiazdka nieaktywnaGwiazdka nieaktywnaGwiazdka nieaktywna
 

Za pomocą funkcji LICZ.JEŻELI mamy możliwość policzenia komórek, które spełniają dane kryteria. W kryteriach wyszukiwania możemy używać symboli wieloznacznych. Za pomocą znaku tylda (~) wyszukujemy znaku zapytania, gwiazdki.

 

Symbole wieloznaczne:

  • Znak zapytania (?) – reprezentuje pojedynczy znak
  • Znak gwiazdki (*) – reprezentuje dowolną liczbę znaków 

 

Składnia funkcji LICZ.JEŻELI LibreOffice Calc:

LICZ.JEŻELI(Zakres, Kryteria)

 

LICZ.JEŻELI przykłady:

 

Przykład 1. LICZ JEŻELI zawiera tekst

Zliczamy tylko komórki, które zawierają tekst, pomijamy liczby i puste komórki (rys. 1.). Najpierw sprawdzamy, czy w komórkach od A2 do A11 występuje tekst - formuły sprawdzające wpisujemy w komórkach od C2 do C11.

=CZY.TEKST(A2)
=CZY.TEKST(A3)
=CZY.TEKST(A4)
=CZY.TEKST(A5)
=CZY.TEKST(A6)
=CZY.TEKST(A7)
=CZY.TEKST(A8)
=CZY.TEKST(A9)
=CZY.TEKST(A10)
=CZY.TEKST(A11)

 

Następnie zliczamy wyniki z kolumny C (od C2 do C11), za pomocą formuły umieszczonej w komórce C15.

=LICZ.JEŻELI(C2:C11;1)

 

Funkcja CZY.TEKST zwraca wartość logiczną (PRAWDA = 1, FAŁSZ = 0). 

 

Rys. 1. LICZ JEŻELI zawiera tekst – LICZ JEŻELI LibreOffice Calc

Rys. 1. LICZ JEŻELI zawiera tekst – LICZ JEŻELI LibreOffice Calc

 

Przykład 2. LICZ JEŻELI zawiera fragment tekstu

A arkuszu kalkulacyjnym do komórek w kolumnie B zostały wprowadzone imiona. Formuła LICZ.JEŻELI ma za zadanie zliczyć imiona zaczynające się na literę A. Do wykonania zadania użyliśmy symbolu wieloznacznego gwiazdka (*). Imiona zostały wprowadzone w komórkach od B2 do B22 (rys. 2.).

=LICZ.JEŻELI(B2:B22;"A*")

 

Rys. 2. LICZ JEŻELI zawiera fragment tekstu - LICZ JEŻELI LibreOffice Calc

Rys. 2. LICZ JEŻELI zawiera fragment tekstu - LICZ JEŻELI LibreOffice Calc

 

Przykład 3. LICZ JEŻELI zawiera wyraz TAK

Zliczamy tylko komórki, które zawierają wyraz TAK (rys. 3.).

=LICZ.JEŻELI(A1:A11;"TAK") 

 

Rys. 3. LICZ JEŻELI zawiera wyraz TAK - LICZ JEŻELI LibreOffice Calc

Rys. 3. LICZ JEŻELI zawiera wyraz TAK - LICZ JEŻELI LibreOffice Calc

 

Przykład 4. LICZ JEŻELI liczba

Liczymy komórki od A2 do A11, które zawierają liczby i są niepuste (rys. 4.)

=LICZ.JEŻELI(A2:A11;">=0")+LICZ.JEŻELI(A2:A11;"<0")

 

Rys. 4. LICZ JEŻELI liczba - LICZ JEŻELI LibreOffice Calc

Rys. 4. LICZ JEŻELI liczba - LICZ JEŻELI LibreOffice Calc

 

Przykład 5. LICZ JEŻELI data

Liczymy daty od komórki A2 do A12, liczby całkowite reprezentują daty (rys. 5.)

=LICZ.JEŻELI(A2:A12;">="&DZIŚ())+LICZ.JEŻELI(A2:A12;"<"&DZIŚ())

 

Rys. 5. LICZ JEŻELI data - LICZ JEŻELI LibreOffice Calc

Rys. 5. LICZ JEŻELI data - LICZ JEŻELI LibreOffice Calc

 

Przykłady zaprezentowane w artykule znajdziemy w pliku licz-jezeli-libreoffice-calc-kurs.zip, zostały zrealizowane na wersji LibreOffice 7.1.1.2.

 

Książki Helion